Tags

, , ,

We previously reported that neither the EBSCOhost database, nor our Voyager catalog system worked with Google Chrome. We were just informed by EBSCOhost that they have fixed the compatibility issue, so can now use Google Chrome when you’re using EBSCOhost database. However, the catalog remains incompatible. Please stick with us as we continue to work towards a solution.

Advertisements